2017年5月22日 (月)

CPUファンを修理する

自宅サーバ用として稼働しているAsus製のEee-Box EB1007が1月くらい前から異音を発生するようになっていた。
2~3日前位からは更に振動音が大きくなってきたが、その後異音がしなくなった。

空冷用ファンがついに止まってしまった様なのでPCのCPU温度を調べたら94℃まで上昇しており、これは拙いとシャットダウンさせた。

私の記憶だと連続稼働している機器のファンの寿命は3~5年だった筈なので、約6年間24時間稼働していたFANが寿命を迎えたとしてもまあおかしくないのかもしれない。

続きを読む "CPUファンを修理する"

| | コメント (0) | トラックバック (0)

2012年8月18日 (土)

NETGEARのGS108Ev2を買ってみた。_その2

前回自宅サーバPCのNICがGbitHUBとLINK UPできなかった件の続き。

続きを読む "NETGEARのGS108Ev2を買ってみた。_その2"

| | コメント (0) | トラックバック (0)

2012年8月10日 (金)

NETGEARのGS108Ev2を買ってみた。

前から予告していたHUBのお話。

続きを読む "NETGEARのGS108Ev2を買ってみた。"

| | コメント (0) | トラックバック (0)

2009年5月30日 (土)

自宅サーバのメンテナンスで

たまにはちょっとネットワーク寄りなお話を。

続きを読む "自宅サーバのメンテナンスで"

| | コメント (0) | トラックバック (0)

2009年5月28日 (木)

saiで落書き(+画面録画試験)の8

saiで落書きの4でやった画面録画を録画条件変更で再度試験してみるのこと。

続きを読む "saiで落書き(+画面録画試験)の8"

| | コメント (0) | トラックバック (0)

2008年7月29日 (火)

ルータが・・・

Adslルータが雷でお亡くなりになりました。

こう云うときに代替の接続手段がないとお手上げですね。
まあネットみるだけなら他の手段が使えるからまだいいけど、自宅サーバへのアクセスができなくなるのはちょっと痛い。
メールが特に。

とりあえずPHSからネットに繋いででNiftyのサポート電話探して電話してみました。
代替機の手配に2、3日掛かるらしいです。

まあ液晶モニタも画面が完全に消えたくらいだからなあ。
一瞬停電かと思ったからなあ。
他の機械が壊れなくて良かったです。
って後から壊れてるのが判ると嫌だなあ。
-----------------
sent from W-ZERO3

| | コメント (4) | トラックバック (0)

2007年3月22日 (木)

airproxyを設置する

前回試したairproxyを自宅サーバに設置してみたのである。

続きを読む "airproxyを設置する"

| | コメント (0) | トラックバック (1)

2007年2月17日 (土)

airproxyを使ってみる

WILLCOMのサービスに高速化というメニューがある。
月額315円で画像の圧縮率を上げて(画質を下げてとも言う)表示速度を上げるというサービスである。
それを自前でやってしまおうというのがairproxyなのである。

今回はこれを導入してみるのである。
しかしWindowsやUnix系で動くソフトなので、自宅サーバが無いと設置は出来ないのだ。
持ってて良かった自宅鯖なのである。

という訳で久々の技術系記事なのである。

続きを読む "airproxyを使ってみる"

| | コメント (2) | トラックバック (1)

2006年9月19日 (火)

サーバプログラムのアップデート

本日は自宅サーバのメンテナンスを実施したのである。
思い立ったが吉日なのである。

続きを読む "サーバプログラムのアップデート"

| | コメント (0) | トラックバック (0)

2005年8月14日 (日)

自宅サーバの再構築

以前から懸案であった自宅サーバ用PCの再構築を昨日に行った。

前回ハードディスクの引越しは見事に失敗したので、今回はハードディスクの入れ替え及びOSレベルからの再インストールである。

現状自宅サーバPCにはCD-ROMドライブとFDDは接続されていないので接続し、HDDを入れ替え後OSのインストールを行った。

OSはWindowsXPからWindows2000に変更することにした。
XPはニューマシン用にしてしまったからだ。

OSをインストール後、メーカサイトよりドライバのダウンロード及びインストールを実施するが何故かVGAが16色800*600にしかならない。

ドライバの再インストール、VGAの削除等色々試してみるが状況は変わらない。
とりあえずメーカのサイトに新しいBIOSが在ったので説明を読んでみると、新しいVGAドライバを使うにはBIOSをアップデートしないとだめらしい。

古いVGAドライバはサイトには見当たらなかったのでBIOSをアップグレードすることにしてみた。
だが私の自宅サーバ用PCはEPIA-MのC3-933というタイプなのだが、サイトのBIOSはEPIA-MのC3-1Gとかいてあるのだ。

イマイチ不安であったがC3-1GとC3-933はクロックの違いだけの筈なので、問題ないだろうとアップデートしてみた。
まあ失敗したらそれはその時である。

このマザーボードはUSB-FDDをサポートしているので早速USB-FDDから立ち上げてBIOSをアップデートしてみた。

書き込みソフトを立ち上げて、BIOSイメージファイルを指定したのだが何故だか見つからないというメッセージが出る。
書き込みソフトを終了させると、Aドライブが使用できなくなっている。
どうも書き込みソフトを立ち上げたらUSBが使用出来なくなっている様なのだ。

となると、普通のFDDを用意しなければいけない。
現在未使用のPCから3.5インチFDDを取り外して、早速自宅サーバ用PCに接続した。
今度はBIOSのアップデートはうまくいったので早速OSを起動してみた。

しかし今度は画面がなんだかずれているのである。
多分BIOSの各種設定をやり直さないといけないのだろうと思い、再起動実施後BIOSの設定を一旦DEFAULTにして再度設定をやり直してみた。

今度は画面が正常に表示され問題なく立ち上がった。
VGAも32BIT1280*1024で問題なく表示されているのである。

その後OSのファイル更新をWindowsupdateから行った。
これが一番めんどくさい。
Windowsupdateへ接続、適用ファイルのチェック及びインストール、再起動後またWindowsupdateへ接続と、このルーチンを相当回数こなさねばならないのだ。

ようやくアップデートが終了、再起動をかけたら何故だかLANが繋がらない。
LANポートのLEDがPC側で消灯しているのである。
一度LANケーブルを抜き差ししたら、今度はLINK UPのLEDが激しく点滅しはじめたのである。

以前Windows2000でサーバを動かしていた時もLANポートがおかしかったので、PCIスロットにLANカードを挿して運用していたのだが、XPでは問題なく動いていたのでどうもドライバの問題の様である。

最後のリブートまでは問題なかったので、その前のアップデートに問題がありそうなのである。
確かに最後のアップデート時にLANのドライバが更新リストにあったので、もう一度メーカのLANドライバを再インストールしてみた。

どうやらこれで直ったようである。
Microsoftのサイトにあるからといってどうやら信用できるとは限らないようだ。

OSのインストールまでは完了したので次はアプリケーションのインストールである。

まずはバーチャルPCをインストールである。
今回サーバを再構築するに当たって、バーチャルPCを利用する事にしていたのだ。

バーチャルPC上に各種サーバを構築すれば、バーチャルPCのファイルだけ新しいPCに移行すればそのまま設定が引き継げるのである。
つまりバーチャルPCさえインストールしておけば、どのPCでも自宅サーバとして稼動させられる様になるのだ。
便利なのである。

事前にメインPCのバーチャルPC上に各種サーバ環境は構築しておいたので、自宅サーバPCにバーチャルPCをインストールして設定ファイルをコピーするだけである。

バーチャルPCをインストール後、自宅サーバPCに設定ファイルを移行すべくバーチャルPCを起動した。
すると無常にも”このPCではバーチャルPCを起動できません”もメッセージが!

VIAのC-3ではバーチャルPCは動かせないようなのである。
おそらくソフトのCPUチェックにVIAのCPUは登録されていないのであろう。

動作にはP-II以上が必要だとのメッセージも出ていたので、MicroSoftではVIA C-3 933MHzはP-IIにも劣るCPUと認識しているということなのである。
それとも最初から眼中になかったのであろうか?

とにかく事前に準備作業は無駄になってしまったのである。
自宅サーバのバーチャルPC上での稼動計画は見事頓挫してしまったので、しかたなく普通にサーバソフトをインストールする事にした。

まずはActivePerl・PHP・ImageMagickをインストール、MySQL・phpMyadminをインストール後04WebServerを立ち上げる。
ブラウザよりPHP及びphpMyadminの動作確認後、phpMyadminからMySQLにMovableType用のアカウントとデータベースを作成した。

次にMovableTypeをインストール、blogを作成後にXmail及びXmailcfg・k4もインストールしてメールサーバを立ち上げた。
メールの設定は前のメールサーバからコピーして引継ぎ、xmailcfgからメールアカウント・メールボックス等以前の設定が正常に引き継がれたことを確認した。

その後MovableTypeから記事を投稿、コメント投稿にて通知メールがxmailサーバに正常に届くことを確認し一通りの作業が終了したのである。

移行作業はこれで一段落付いたので早速この記事を投稿しているところである。
この記事を自宅サーバのMovableTypeで投稿、記事の書き出しでココログにインポートするのである。
ココログに無事投稿されていれば今回の一連の作業は終了なのである。

ココログでの追記:
無事インポートすることが出来た。
これで今回の作業は終了なのである。

| | コメント (0) | トラックバック (0)